• 2529阅读
  • 1回复

易语言清除文本型数组中相同成员 [复制链接]

上一主题 下一主题
离线oloooo
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2017-01-12

.版本 2

.子程序 清除数组相同成员, 逻辑型
.参数 数组, 文本型, 数组, 需要清除的数组
.参数 lss, 文本型, 数组, 需要接收的数组
.局部变量 ls, 文本型, , "0"
.局部变量 TU, 整数型
.局部变量 TI, 整数型
.局部变量 dl, 整数型
.局部变量 计次, 整数型
.局部变量 LI, 整数型, , "0"

清除数组 (ls)
清除数组 (LI)
ls = 数组
TI = 0
dl = 0
TU = 0
.判断循环首 (TU ≠ 取数组成员数 (ls))
    TU = TU + 1
    .判断开始 (TU ≠ 取数组成员数 (ls))
        .判断循环首 (TI ≠ 取数组成员数 (ls))
            TI = TI + 1
            .判断开始 (TI = 取数组成员数 (ls) 且 TU = TI)
                dl = 1
            .默认
                .如果真 (TU = TI)
                    TI = TI + 1
                .如果真结束

            .判断结束

            .如果真 (ls [TU] = ls [TI] 且 dl ≠ 1)

                加入成员 (LI, TI)
            .如果真结束

        .判断循环尾 ()
        .计次循环首 (取数组成员数 (LI), 计次)
            删除成员 (ls, LI [取数组成员数 (LI) - 计次 + 1], )
            .判断开始 (计次 = 取数组成员数 (LI))
                清除数组 (LI)
            .默认

            .判断结束

        .计次循环尾 ()
    .默认

    .判断结束

    TI = 0
.判断循环尾 ()
lss = ls
返回 (真)


自己写的在俺的电脑上测试没问题       喜欢的各位可以试试
离线cui19951005

只看该作者 沙发  发表于: 2017-01-12
学习啦
快速回复
限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个