• 3207阅读
  • 1回复

易语言无边框窗口发送消息  控制窗口大小 [复制链接]

上一主题 下一主题
离线oloooo
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2017-01-10

.版本 2

.子程序 __启动窗口_鼠标左键被按下, 逻辑型
.参数 x, 整数型
.参数 y, 整数型
.参数 u, 整数型
.局部变量 l, 整数型, 静态, , 鼠标指针判断变量

.判断开始 (_启动窗口.宽度 > 400 且 _启动窗口.高度 > 200)
    Tps = 1
    .判断开始 (x < 4 且 y < 取用户区高度 () - 6 且 y > 6)
        l = 1
        .判断开始 (l = 1)
            _启动窗口.发送信息 (274, 61441, 0)  ' 左边
        .默认

        .判断结束

    .判断 (x > 取用户区宽度 () - 4 且 y < 取用户区高度 () - 6 且 y > 6)
        l = 2
        .判断开始 (l = 2)
            _启动窗口.发送信息 (274, 61442, 0)  ' 右边
        .默认

        .判断结束

    .判断 (y < 4 且 x < 取用户区宽度 () - 6 且 x > 6)
        l = 3
        .判断开始 (l = 3)
            _启动窗口.发送信息 (274, 61443, 0)  ' 顶边
        .默认

        .判断结束

    .判断 (y > 取用户区高度 () - 4 且 x < 取用户区宽度 () - 6 且 x > 6)
        l = 4
        .判断开始 (l = 4)
            _启动窗口.发送信息 (274, 61446, 0)  ' 下边
        .默认

        .判断结束

    .判断 (x < 6 且 y < 6)
        l = 5
        .判断开始 (l = 5)
            _启动窗口.发送信息 (274, 61444, 0)  ' 左上
        .默认

        .判断结束

    .判断 (x > 取用户区宽度 () - 6 且 y < 6)
        l = 6
        .判断开始 (l = 6)
            _启动窗口.发送信息 (274, 61445, 0)  ' 右上
        .默认

        .判断结束

    .判断 (x > 取用户区宽度 () - 6 且 y > 取用户区高度 () - 6)
        l = 7
        .判断开始 (l = 7)
            _启动窗口.发送信息 (274, 61448, 0)  ' 右下
        .默认

        .判断结束

    .判断 (x < 6 且 y > 取用户区高度 () - 6)
        l = 8
        .判断开始 (l = 8)
            _启动窗口.发送信息 (274, 61447, 0) ' 左下
        .默认

        .判断结束

    .默认

    .判断结束
离线cui19951005

只看该作者 沙发  发表于: 2017-01-10
学习啦,谢谢楼主
快速回复
限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
上一个 下一个