• 3136阅读
  • 0回复

易语言关于在OnMessage事件中lParam参数转换坐标 [复制链接]

上一主题 下一主题
离线oloooo
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-12-30
不太懂MSDN
请教各位大神不知道我的转换方式是否有问题:

.版本 2

.子程序 _Player1_OnMessage
.参数 nMessage, 整数型
.参数 wParam, 整数型
.参数 lParam, 整数型
.局部变量 x1, 整数型
.局部变量 y1, 整数型
.局部变量 y, 整数型
.局部变量 x, 整数型

y1 = lParam ÷ 65535
y = y1 + 1
x1 = lParam - (y1 × 65535 + y1)
x = x1 + 1
编辑框3.内容 = “X坐标:” + 到文本 (x) + “    ” + “Y坐标:” + 到文本 (y)

快速回复
限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个