• 8890阅读
  • 13回复

易语言 调整窗口大小,视频跟随大小,希望给个列子 [复制链接]

上一主题 下一主题
离线chinaaxin
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2015-08-27
setwindowpos 我使用了无效,我是易语言用户
谢谢
离线chinaaxin

只看该作者 沙发  发表于: 2015-08-27
管理员 你好 希望你出个易语言 播放容器区域随窗口调整大小的列子,我试好久了,还没搞定。
离线追风295

只看该作者 板凳  发表于: 2015-08-27
回 chinaaxin 的帖子
chinaaxin:管理员 你好 希望你出个易语言 播放容器区域随窗口调整大小的列子,我试好久了,还没搞定。 (2015-08-27 14:25) 

http://aplayer.open.xunlei.com/bbs/read.php?tid=23658&fpage=5
上面地址是用到的模块地址
下面是我参照写的代码希望可以帮到你,这个我也很纠结。用无边框的窗口,设置不了顶边参数,设置了也不行。如果你可以解决告诉我一下。谢谢了

.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 播放器, APlayer类

.子程序 __启动窗口_创建完毕

播放器.创建AP (取窗口句柄 (), 3, 30, 600, 360, , , , , , , , )
' 播放器.写引擎设置 (3, “{09571A4B-F1FE-4C60-9760-DE6D310C7C31}”)
' 播放器.打开文件或URL (“E:\迅雷下载\新建文件夹\115435.mp4”)
播放器.置图标 (#图标)

.子程序 _关闭按钮_被单击

结束 ()

.子程序 _按钮1_被单击

播放器.移动 (3, 30, 取用户区宽度 () - 10, 取用户区高度 () - 80)
超级列表框1.可视 = 假

.子程序 _按钮2_被单击

播放器.移动 (3, 30, 取用户区宽度 () - 194, 取用户区高度 () - 80)
超级列表框1.可视 = 真

离线caj518anji_1

只看该作者 地板  发表于: 2015-08-27
我是楼主,问题已经自行解决,

是我自己封装的AP引擎的模块出了问题 已修正
离线caj518anji_1

只看该作者 4楼 发表于: 2015-08-27
回 追风295 的帖子
追风295:http://aplayer.open.xunlei.com/bbs/read.php?tid=23658&fpage=5
上面地址是用到的模块地址
下面是我参照写的代码希望可以帮到你,这个我也很纠结。用无边框的窗口,设置不了顶边参数,设置了也不行。如 .. (2015-08-27 16:43) 

已私信 给你 我没用模块
离线stm1

只看该作者 5楼 发表于: 2015-10-02
求调用接口!
离线dncong

只看该作者 6楼 发表于: 2015-11-27
楼主怎么解决的
离线aplayer

只看该作者 7楼 发表于: 2015-11-27
回 dncong 的帖子
dncong:楼主怎么解决的 (2015-11-27 14:50) 

SetWindowPos 的窗口句柄要从 APlayerCaller.dll 的  APlayer_GetWindow 函数获取即可。
离线chenyw101

只看该作者 8楼 发表于: 2015-11-28
高手如云啊
离线leejunlong

只看该作者 9楼 发表于: 2015-12-09
3q3q
快速回复
限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
上一个 下一个