• 2886阅读
  • 5回复

如何在播放器内输出文字 [复制链接]

上一主题 下一主题
离线dan5558
 

只看楼主 正序阅读 使用道具 楼主  发表于: 2017-02-27
例如:静音/取消静音
离线hlwdy

只看该作者 5楼 发表于: 2019-01-19
总算找到了这个方法
离线lcz410323

只看该作者 4楼 发表于: 2017-10-17
学习了
离线langmanyingh

只看该作者 地板  发表于: 2017-08-12
楼主,是否有用?
迅游棋牌xunyouqipai.com
离线54586312

只看该作者 板凳  发表于: 2017-08-06
.版本 2

.DLL命令 APlayer_GetConfigA, 文本型, "pekernel.dll", "APlayer_GetConfigA", , 设置媒体
    .参数 aplayer, 整数型
    .参数 nConfigId, 整数型
不能没那么,,
离线54586312

只看该作者 沙发  发表于: 2017-08-06
.版本 2

.DLL命令 APlayer_SetConfigA, 整数型, "pekernel.dll", "APlayer_SetConfigA", , SetConfig 方法用来设置 APlayer 引擎。
    .参数 aplayer, 整数型
    .参数 configid, 整数型
    .参数 strVal, 文本型
-------------------------------------------------------------------------------
.版本 2

.子程序 置_叠图开启, 逻辑型, , 设置一段文本作为叠加图像,参数为 提示文本,支持回车换行符主动换行和自动换行。成功返回 真,失败返回 假。销毁该文本调用 <销毁提示文本> 命令。用处:例如改变音量时在视频左上角提示当前音量
.参数 提示文本, 文本型, , 参数为 提示文本,支持回车换行符主动换行和自动换行
.参数 左边, 整数型, , 提示文本左上角水平位置
.参数 顶边, 整数型, , 提示文本左上角垂直位置
.局部变量 是否可用, 逻辑型
-------------------------------------------------------------------------------
.判断开始 (置_Get方法 (601) = “1”)
    APlayer_SetConfigA (媒体数据, 602, “1”)
    APlayer_SetConfigA (媒体数据, 606, 到文本 (左边))
    APlayer_SetConfigA (媒体数据, 607, 到文本 (顶边))
    APlayer_SetConfigA (媒体数据, 612, 提示文本)
.默认
    是否可用 = 真
    是否可用 = 假
.判断结束
返回 (是否可用)
-------------------------------------------------------------------------------
.版本 2

.子程序 置_Get方法, 文本型, , 设置 APlayer播放器。该方法下的参数 [设置ID] 仅支持 常量表中以 R_ /RW_ 开头的常量。参数设置详情参考文档-->Aplayer设置参考手册。
.参数 设置ID, 整数型, , 设置的编号,仅支持常量表中以 R_ /RW_ 开头的常量。各类型设置编号参数,详情参考文档-->Aplayer事件参考手册。

返回 (APlayer_GetConfigA (媒体数据, 设置ID))

.版本 2

.子程序 _音量条_位置被改变

置_叠图开启 (“音量:” + “” + “%”, 10, 10)  ' “” 双引号 带表内容
不能没那么,,
快速回复
限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
上一个 下一个