• 5063阅读
  • 5回复

APlayer播放引擎怎么再换面上写字?  比如播放时提示什么 [复制链接]

上一主题 下一主题
离线18736712110
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2015-11-29
如题,就是想让播放器播放中在左上角显示播放的视频名称,比如缓冲的时候在画面左上角提示:“正在缓冲100% ”
我用易语言窗口写字方法可以上写去但是会出现闪烁的问题。
不清楚aplayer是否提供这个接口!

帮助文档不知怎么回事在我电脑上打不开!

离线aplayer

只看该作者 沙发  发表于: 2015-11-29
可以使用叠图中叠加文字的功能,文档中有,帮助文档打不开的问题这样解决:
在打开文档之前的那个提示框    "打开该文档类型总是提示”  的勾选去掉,重新打开即可。
离线18736712110

只看该作者 板凳  发表于: 2015-11-29
回 aplayer 的帖子
aplayer:可以使用叠图中叠加文字的功能,文档中有,帮助文档打不开的问题这样解决:
在打开文档之前的那个提示框    "打开该文档类型总是提示”  的勾选去掉,重新打开即可 .. (2015-11-29 13:23) 

翻了半天没找到! 能不能给写下易语言调用的例子?
离线chungbin

只看该作者 地板  发表于: 2015-11-30
离线chungbin

只看该作者 4楼 发表于: 2015-11-30
.版本 2
.支持库 iext6

.子程序 _音量条_位置被改变

设置音量 (aplayer, 音量条.位置)
.如果真 (音量条.位置 = 100)
    视频叠图加功能 ()
    设置引擎配置 (aplayer, 612, “已到最大音量 100%,可按↑继续增大音量”)
    叠图时钟.时钟周期 = 3000
.如果真结束
.如果真 (音量条.位置 = 0)
    音量按钮.正常图片 = 读入文件 (skin + “\” + 读配置项 (skin + “\config.ini”, “皮肤文件”, “音量按钮禁止图片”, ))
    视频叠图加功能 ()
    设置引擎配置 (aplayer, 612, “静音”)
    叠图时钟.时钟周期 = 3000
.如果真结束
.如果真 (音量条.位置 > 0 且 音量条.位置 < 100)
    音量按钮.正常图片 = 读入文件 (skin + “\” + 读配置项 (skin + “\config.ini”, “皮肤文件”, “音量按钮正常图片”, ))
    视频叠图加功能 ()
    设置引擎配置 (aplayer, 612, “音量:” + 到文本 (音量条.位置) + “%”)
    叠图时钟.时钟周期 = 3000
.如果真结束


.子程序 视频叠图加功能

设置引擎配置 (aplayer, 602, “1”)
设置引擎配置 (aplayer, 606, “40”)
设置引擎配置 (aplayer, 607, “20”)
设置引擎配置 (aplayer, 621, “1”)
' 设置引擎配置 (aplayer, 612, “1”)

.子程序 _叠图时钟_周期事件

设置引擎配置 (aplayer, 612, “”)
叠图时钟.时钟周期 = 0
离线追风295

只看该作者 5楼 发表于: 2015-12-06
为什么缓冲完了在提示100%,还有就是提示的字体模糊不清。是什么原因。是视频画质的的问题面
快速回复
限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
上一个 下一个