• 5694阅读
  • 9回复

添加自己的logo  怎么添加不了 [复制链接]

上一主题 下一主题
离线追风295
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2015-08-21

.版本 2

.子程序 __启动窗口_创建完毕
.局部变量 图片句柄, 整数型

图片句柄 = 图片组操作.取图片句柄_从字节集 (#图片logo)
Player1.SetCustomLogo (图片句柄)
' aplayer.SetCustomLogo (1)

aplayer.ins (取运行目录 () + “\APlayerCaller.dll”)
aplayer.CreateAPlayer (图片框1.取窗口句柄 (), 0, 0, 图片框1.宽度, 图片框1.高度, , , , , 到整数 (&OnBuffer), , , )‘创建窗口
新手才学习,请帮助解决一下,感谢。这是论坛的一个代码。创建一个窗口。更改logo更改不了。还有就是在播放列表显示的时候,怎么让播放窗口的尺寸随着改变,
离线liu123204207

只看该作者 沙发  发表于: 2015-08-21
.版本 2

.子程序 取_位图句柄, 整数型, 公开, 取图标句柄,成功返回图标句柄,失败返回0
.参数 参_图标, 字节集, , 欲添加为菜单图标的资源
.局部变量 局_对象, 对象, 静态, "0"
.局部变量 局_句柄, 整数型
.局部变量 局_成员数, 整数型

局_成员数 = 取数组成员数 (局_对象) + 1
重定义数组 (局_对象, 真, 局_成员数)
.如果真 (局_对象 [局_成员数].创建图片对象 (参_图标))
    返回 (局_对象 [局_成员数].读数值属性 (“handle”, ))
.如果真结束
返回 (0)

.版本 2

aplayer = CreateAPlayer (_启动窗口.取窗口句柄 (), 0, 0, _启动窗口.取用户区宽度 (), _启动窗口.取用户区高度 () - 50, 0, 0, 到整数 (&OnOpenSuccess), 0, 0, 0, 到整数 (&OnDownloadCodec), 到整数 (&OnEvent))
SetCustomLogo (aplayer, 取_位图句柄 (#图片1))



哦也
离线xushen

只看该作者 板凳  发表于: 2015-08-21
请参考一楼
http://www.huankv.com/
离线追风295

只看该作者 地板  发表于: 2015-08-21
回 liu123204207 的帖子
liu123204207:.版本 2
.子程序 取_位图句柄, 整数型, 公开, 取图标句柄,成功返回图标句柄,失败返回0
.参数 参_图标, 字节集, , 欲添加为菜单图标的资源
.局部变量 局_对象, 对象, 静态, "0"
....... (2015-08-21 14:22) 

十分感谢添加自定义图标已解决。怎么使已经创建APlayer窗口宽度在播放列表显示以后,它的宽度随着变化(小)
离线有妖气

只看该作者 4楼 发表于: 2015-08-22
又是易语言。。。。帮不了你。。。。。。
修身齐家治国平天下
离线liu123204207

只看该作者 5楼 发表于: 2015-08-22
看这里
哦也
离线liu123204207

只看该作者 6楼 发表于: 2015-08-22
哦也
离线追风295

只看该作者 7楼 发表于: 2015-08-23
回 liu123204207 的帖子
liu123204207:看这里 (2015-08-22 22:15) 

播放币不够啊
离线a871516130

只看该作者 8楼 发表于: 2015-11-12
播放币不够啊
离线a871516130

只看该作者 9楼 发表于: 2015-11-12
快速回复
限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个