• 3031阅读
  • 3回复

汗一个,aplayer怎办开启硬件加速? [复制链接]

上一主题 下一主题
离线lygyue
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2015-03-05
g_MyPlayer.m_pAPlayer->SetConfig(209, "1");
g_MyPlayer.m_pAPlayer->SetConfig(209, _bstr_t("1"));
g_MyPlayer.m_pAPlayer->SetConfig(209, _bstr_t(1));
我都试过了,全是失败。

_bstr_t CMyPlayer::GetConfigStr(int nConfigId)
{
    USES_CONVERSION;
    _bstr_t strConfig = m_pAPlayer->GetConfig(nConfigId);

    return strConfig;
}
返回全是0.。我想死。

管理,能放点使用资料,demo 之类的出来吗,这样搞要死人的。
离线lygyue

只看该作者 沙发  发表于: 2015-03-05
获取时我用209返回是1,用211返回是0.我确定没开启成功的原因是cpu占用率一点也没变。
离线chungbin

只看该作者 板凳  发表于: 2015-03-06
.版本 2
.支持库 APlayer_3.8.1.705
.支持库 ExtMenu

.判断开始 (aPlayer.GetConfig (209) = “0”)
    aPlayer.SetConfig (209, “1”)
    .如果真 (aPlayer.GetConfig (209) = “1”)
        播放器右键菜单.置菜单项图片 (硬件加速, 0)
        视频叠图加功能 ()
        aPlayer.SetConfig (612, “硬件加速开启成功”)
        时钟2.时钟周期 = 3000
    .如果真结束

.默认
    aPlayer.SetConfig (209, “0”)
    .如果真 (aPlayer.GetConfig (209) = “0”)
        播放器右键菜单.置菜单项图片 (硬件加速, -1)
        视频叠图加功能 ()
        aPlayer.SetConfig (612, “硬件加速已关闭”)
        时钟2.时钟周期 = 3000
    .如果真结束

离线aplayer

只看该作者 地板  发表于: 2015-03-06
搂主你好硬件加速需要在 Open 之前设置。
如果半途开启则需要重新 Open 并 SetPosiiton 到当前上次位置。
快速回复
限100 字节
批量上传需要先选择文件,再选择上传
 
上一个 下一个